Learn365 インストールに関する主な問題と解決策

  • 更新

ここでは、Learn365 インストール中に発生するエラーとその原因、解決方法をご紹介します。

 

Unfortunately, we cannot find a SharePoint App Catalog on your Office 365 Tenant.
(Office 365 テナント上に SharePoint アプリ カタログ が見つかりません)

 

エラー全文:

"Unfortunately, we cannot find a SharePoint App Catalog on your Office 365 Tenant. Please follow the Microsoft instructions on how to create a SharePoint App Catalog. Once you've created it, you can return to this page, refresh it, then continue the setup process. Note: If it was recently created SharePoint might needs some time to make it available for us, please try again a little later."

申し訳ありませんが、お使いの Office 365 テナントに SharePoint アプリ カタログが見つかりません。SharePoint アプリ カタログを作成する方法については、Microsoft の手順に従ってください。作成後、このページに戻って更新し、セットアップ プロセスを続行してください。注: SharePoint アプリ カタログを最近作成した場合、利用可能になるまで少し時間がかかることがあります。その場合は、しばらくしてから再度お試しください。

原因:

このエラーは、SharePoint 管理センターで SharePoint アプリ カタログが作成されていない場合に、インストール プロセス中に発生することがあります。

解決策:

「View Microsoft instructions(Microsoft の手順を表示)」を選択し、SharePoint Online でアプリ カタログ サイトを作成する方法を確認してください。 この処理には最大で 20分ほどかかる場合があります。

SharePoint アプリ カタログが別のアカウントによって作成されており、ご自身のアカウントに必要な権限が付与されていない場合、以下のエラーに関する手順を参照してください。

"We were unable to verify your Office 365 setup, please try again later. If the issue persists, please contact your LMS365 Administrator"

 

"The SharePoint App Catalog is unavailable. Ensure that it has been created and the account you are using has at least 'Visitor' permissions."
(SharePointアプリカタログが使用できません。アプリカタログを作成し、使用するアカウントのアクセス許可が少なくとも”閲覧者”であることを確認してください。)

 

エラー全文:

"The SharePoint App Catalog is unavailable. Ensure that it has been created and the account you are using has at least 'Visitor' permissions.If the App Catalog was created recently, SharePoint might need some time to make it available for LMS365."

SharePoint アプリ カタログを利用できません。アプリ カタログが作成されていること、また、使用しているアカウントに少なくとも「閲覧者(Visitor)」権限が付与されていることを確認してください。 アプリ カタログが最近作成された場合、Learn365 で利用できるようになるまでに少し時間がかかることがあります。

原因:

このエラーは、SharePoint 管理センターで SharePoint アプリ カタログが作成されていない場合に、インストール プロセス中に発生することがあります。

解決策:

アプリ カタログが作成され、利用可能な状態であることを確認してください。このプロセスには 最大で 20 分程度かかる場合があります。少し時間を置いてから、再度お試しください。
詳細については、「View Microsoft instructions(Microsoft の手順を表示)」を選択し、SharePoint Online でアプリ カタログ サイトを作成する方法をご確認ください。

 

"We were unable to verify your Office 365 setup, please try again later. If the issue persists, please contact your LMS365 Administrator"
(Office 365のセットアップを確認できませんでした。問題が解決しない場合は、LMS365管理者にお問い合わせください。)

 

この問題には、2つの原因が考えられます。

原因 1:

アカウントの SharePoint ルート サイトへのアクセス権限が正しく設定されていません。

解決策:

Microsoft 365 グローバル管理者 または SharePoint 管理者が、SharePoint のルート サイトに移動し、使用しているアカウントに対して適切な権限を付与します。

SharePoint ルート サイトについて:

ルート サイトとは、URL の末尾が sharepoint.com で終わり、/sites が含まれないサイトのことです。

ルート サイトへ移動する方法:

1.SharePoint 管理センターに移動します。
2.「アクティブなサイト」を選択します。
3.「サイト名」列のメニューを展開し、A → Z(昇順)で並び替え、一覧の一番上に表示されるサイトが「ルート サイト」です。
ルート サイトが一覧の先頭に表示されない場合は、次の URL を直接ブラウザーに貼り付けてアクセスすることもできます。

https://YOUR-TENANT-NAME.sharepoint.com

ルート サイトとは何か、また、ルート サイトの設定方法や置き換え方法についての詳細は、こちらの Microsoft のガイドをご参照ください。

 

原因 2:

使用しているアカウントに Learn365 をインストールするための十分な権限が付与されていません。

解決策:

インストールに使用しているアカウントに必要な権限を付与します。

必要な権限を割り当てる手順:

1.Microsoft 365 グローバル管理者 または SharePoint 管理者 としてSharePoint 管理センターにアクセスします。

2.「アクティブなサイト」>ルート サイトを選択します。

3.コマンドバーの「Membership」を選択すると、サイト管理パネルの「メンバーシップ」タブが開きます。

4.少なくとも「サイトの訪問者」に Learn365 のインストールに使用するアカウントを追加します。

installation issue2.png

その他の方法として、必要な権限を持つアカウントを所有しているユーザーに依頼して権限を付与してもらうか、必要な権限を持つ別のアカウントを使用します。

 

"The SharePoint App Catalog is unavailable. Ensure that the account you are using has at least 'Owner' permissions."
(SharePoint アプリ カタログは使用できません。使用しているアカウントのアクセス許可が少なくとも「所有者」であることを確認してください。)

 

原因:

使用しているアカウントに、SharePoint アプリ カタログ にアクセスするための権限が不足しています。 Microsoft 365 グローバル管理者であっても、管理者が複数存在する環境ではルート サイトやアプリ カタログ サイトの権限を必ずしも持っていない場合があります。 既定では、そのサイトを作成したユーザーのみが権限を有します。

解決策:

SharePoint アプリ カタログ にアクセスするために、使用しているアカウントに必要な権限を付与します。

アプリ カタログ の権限を設定する手順:

1.Microsoft グローバル管理者 または SharePoint 管理者 として SharePoint 管理センターにアクセスします。

2.「アクティブなサイト」>「アプリカタログ」サイト(.../‎apps‎)を選択します。

3.コマンドバーの「Membership」を選択すると、サイト管理パネルの「メンバーシップ」タブが開きます。

4.「サイトの所有者」に Learn365 のインストールに使用するアカウントを追加します。

その他の方法として、必要な権限を持つアカウントを所有しているユーザーに依頼して権限を付与してもらうか、必要な権限を持つ別のアカウントを使用します。

※補足:アプリ カタログ サイトの権限は、自動では継承されません。
管理者ロールを持っていても、明示的にアプリ カタログ サイトへの権限付与が必要なケースがあります。
権限の変更後、反映までに数分かかる場合があります。

 

Oops, something went wrong

 

原因:

Microsoft Entra ID(旧 Azure Active Directory)で行ったアカウントの権限の更新がまだ反映されていません。
Microsoft Entra ID での権限変更が各サービスに反映されるまでに時間がかかる場合があります。

解決策:

Microsoft Entra ID での権限更新には一定の反映時間が必要です。しばらく時間を置いて、ページを更新(再読み込み)し、再度操作を行ってください。

※補足:権限変更直後は、SharePoint や Learn365 側で認識されない場合があります。
明示的なエラーが表示されない場合でも、時間経過により自動的に解消するケースがあります。
他の権限(ルート サイト、アプリ カタログ)が正しく設定されていることも併せて確認してください。

 

"Unfortunately, we could not complete the Region confirmation."
(残念ながら、リージョンの確認を完了できませんでした。)

 

原因:

このエラーは、テナントのリージョンを選択した後に表示されるもので、以下が主な原因です。

  • SharePoint アプリ カタログのプロビジョニングが未完了
  • インストールに使用しているアカウントに必要な権限が付与されていない
  • 解決策:

    SharePoint アプリ カタログの作成プロセスには、最大で 20分程度かかります。
    しばらく時間を置いてからインストール ページを再読み込みし、再度操作してください。

    インストールを実行するアカウントの権限不足が原因で発生している場合は、以下のエラーを参照して権限の設定を確認してください。